Brian Waters | 13d9601 | 2017-12-08 16:53:31 -0600 | [diff] [blame] | 1 | freediameter (1.2.1) UNRELEASED; urgency=low |
| 2 | |
| 3 | * New extension: rt_randomize (load-balancing on possible destinations) |
| 4 | * New contrib: Gx extension. |
| 5 | * rt_redirect.fdx and rt_load_balance.fdx improvement: use a hash table. Thanks Thomas. |
| 6 | * New hook HOOK_MESSAGE_SENDING to give a last chance to edit messages before they are sent. |
| 7 | This will be mostly used for enforcing interoperability constraints on non-compliant peers. |
| 8 | * Simplified log output. Old output can be recovered with DEBUG_WITH_META build option. |
| 9 | * Updated the internal counters for finer control on the load. |
| 10 | * Fixes in message expiry mechanism. |
| 11 | * Bug fixes in error messages generation and various parts. |
| 12 | * Improvements on shutdown sequence handling. |
| 13 | * Improvements to the dict_dcca_* extensions. |
| 14 | * Improved default CMake configuration. |
| 15 | * Improved build for MacOSX |
| 16 | * Fixes for a few newer operating systems compatibility. |
| 17 | * Fixed default secure Diameter port number 5868 instead of5658 (errata of RFC 6733) |
| 18 | |
| 19 | -- Sebastien Decugis <sdecugis@freediameter.net> Sat, 30 Jan 2016 23:38:03 +0800 |
| 20 | |
| 21 | freediameter (1.2.0) UNRELEASED; urgency=low |
| 22 | |
| 23 | * Major changes in the logging system to be more syslog and production friendly |
| 24 | * New extension: dict_dcca_3gpp |
| 25 | * New extension: dict_dcca_starent (Starent DCCA vendor-specific AVPs) |
| 26 | * New extension: rt_ignore_dh (hide network topology by proxying Destination-Host). |
| 27 | * New extension: rt_load_balance (load balancer based on pending queue size). |
| 28 | * New extension: rt_busypeers. See doc/rt_busypeers.conf.sample. |
| 29 | * New extension: dbg_msg_timings. Measures timing of message operations. |
| 30 | * New extension: dbg_msg_dumps. Use to control hooks display. |
| 31 | * New API (fd_hook_*) for extensions to control messages logging & profiling |
| 32 | * New API (fd_stats_*) for extensions to monitor framework state (e.g. SNMP implem) |
| 33 | * API change: all the fd_*_dump functions now return malloc'd strings instead of logging directly. |
| 34 | * API change: callback parameter of fd_rt_out_register had its signature updated. |
| 35 | * Updated dbg_monitoring extension to use the new API |
| 36 | * New script to generate dictionary extensions from org file (see contrib/tools) |
| 37 | * New compilation option: WORKAROUND_ACCEPT_INVALID_VSAI to improve compatibility |
| 38 | with invalid Vendor-Specific-Application-Id AVPs received from some equipments (e.g. Cisco). |
| 39 | * New compilation option: DISABLE_PEER_EXPIRY for use in test environments. |
| 40 | * Extensions are now also searched in LD_LIBRARY_PATH. |
| 41 | * Copy Proxy-Info AVP automatically in new answers. |
| 42 | * Port value 0 allowed in configuration to disable local server (e.g. disable non-secure port). |
| 43 | * API change: fd_msg_send_timeout now takes a separate callback for timeout situation. |
| 44 | * Function changes: fd_msg_dump_* now split in three different type of output. |
| 45 | * New test testmesg_stress to measure message parser performance |
| 46 | * Fix termination of the framework to avoid failures. |
| 47 | * Fix invalid timespec value in peer PSM appearing randomly (leading to crash). |
| 48 | * Return DIAMETER_LOOP_DETECTED if local peer in the Route-Record list of a message. |
| 49 | * Allow running without TLS configuration. |
| 50 | * Upgraded SCTP code to comply with RFC 6458 |
| 51 | * Using default secure Diameter port number 5658 as per RFC 6733 |
| 52 | * Updated TLS code for performance improvements with new GNU TLS. |
| 53 | * Fix interlocking problem when large number of requests were failed over. |
| 54 | * New option in test_app.fdx extension for long messages payload. |
| 55 | * Performance improvement in message sending code path. |
| 56 | |
| 57 | -- Sebastien Decugis <sdecugis@freediameter.net> Sat, 14 Sep 2013 18:08:07 +0800 |
| 58 | |
| 59 | freediameter (1.1.6) UNRELEASED; urgency=low |
| 60 | |
| 61 | * Fix major issue in 1.1.5 preventing to send answers to a received message. |
| 62 | * New command-line option: --enable_msg_log=( DROPPED | RECEIVED | SENT | NODELIVER | TIMING ) |
| 63 | * Improved parsing error handling and Failed-AVP generation. |
| 64 | * Added support for some timings measurements in freeDiameter (in the logs) |
| 65 | * Fix port handling when using non-default port. |
| 66 | * Some cleanups in several dictionary files. |
| 67 | * New option to fd_dict_search: AVP_BY_STRUCT |
| 68 | * Improved compatibility with C++ compilers. |
| 69 | * Cleanups in sessions creation/destruction to avoid memory corruption under stress. |
| 70 | * Add support for "include" directive in freeDiameter.conf file. |
| 71 | |
| 72 | -- Sebastien Decugis <sdecugis@freediameter.net> Sun, 03 Mar 2013 07:40:43 +0100 |
| 73 | |
| 74 | freediameter (1.1.5) UNRELEASED; urgency=low |
| 75 | |
| 76 | * Added compatibility with MAC OS X |
| 77 | * Fix behavior of timeout whe nsending messages to allow re-send. |
| 78 | * Several cleanups and new contributions included. |
| 79 | * Added dependency on C++ compiler for CMakeLists.txt |
| 80 | |
| 81 | -- Sebastien Decugis <sdecugis@freediameter.net> Sat, 03 Nov 2012 17:58:11 +0100 |
| 82 | |
| 83 | freediameter (1.1.4) UNRELEASED; urgency=low |
| 84 | |
| 85 | * Compatibility with GnuTLS 3.x versions / updated packaging files accordingly |
| 86 | * Fix crash on Sparc 64 (possibly other 64b machines) |
| 87 | * Updated dict_dcca in extensions and contrib (thanks Konstantin) |
| 88 | * Changed dumping of messages to avoid interleaved information |
| 89 | |
| 90 | -- Sebastien Decugis <sdecugis@freediameter.net> Fri, 24 Aug 2012 00:17:05 +0200 |
| 91 | |
| 92 | freediameter (1.1.3) UNRELEASED; urgency=low |
| 93 | |
| 94 | * Fixed a memory leak |
| 95 | * Clean-up of some extensions |
| 96 | |
| 97 | -- Sebastien Decugis <sdecugis@freediameter.net> Tue, 03 Jul 2012 08:15:49 +0200 |
| 98 | |
| 99 | freediameter (1.1.2) UNRELEASED; urgency=low |
| 100 | |
| 101 | * FIFO queues are now capped to avoid memory exhaustion. |
| 102 | * Cleanups in MIPv6 dictionaries. |
| 103 | * app_acct upgraded: enabled vendor-specific AVP logging, thread-safe version. |
| 104 | * New function: fd_dict_getlistof to list dictionary contents. |
| 105 | * New function: fd_dict_delete to remove an entry (dangerous function!) |
| 106 | * New function: fd_sess_getcount to get count of session objects. |
| 107 | * A few additional bug fixes, check hg log for details. |
| 108 | |
| 109 | -- Sebastien Decugis <sdecugis@freediameter.net> Tue, 21 Feb 2012 18:38:10 +0100 |
| 110 | |
| 111 | freediameter (1.1.1) UNRELEASED; urgency=low |
| 112 | |
| 113 | * Bug fix release |
| 114 | * Supports newer GNUTLS versions |
| 115 | * Allow empty OctetString AVPs (l=0) |
| 116 | * Allow two instances of freeDiameter on a single host. |
| 117 | |
| 118 | -- Sebastien Decugis <sdecugis@nict.go.jp> Fri, 30 Sep 2011 21:56:50 +0200 |
| 119 | |
| 120 | freediameter (1.1.0) UNRELEASED; urgency=low |
| 121 | |
| 122 | * Source package restructured. Most of the |
| 123 | framework now contained in the libfdcore library. |
| 124 | libfreeDiameter renamed as libfdproto. |
| 125 | This closes #15. |
| 126 | * API version bumped to version 4. |
| 127 | * Improved fd_dict_new() when the same object already exists. |
| 128 | * Improvements to dict_legacy_xml extension. |
| 129 | * Cleanups in links to shared libraries |
| 130 | * (app_radgw.fdx) Better handling conversion of DEA with error status |
| 131 | to RADIUS (closes #25) |
| 132 | * Allow default signals such as SIGTSTP (ctrl-z) to be used with |
| 133 | freeDiameterd |
| 134 | * Improved DiameterIdentity handling (esp. interationalization issues), |
| 135 | and improve efficiency of some string operations in peers, sessions, |
| 136 | and dictionary modules (closes #7) |
| 137 | * Cleanup in the session module to free only unreferenced sessions (#16) |
| 138 | * Removed fd_cpu_flush_cache(), replaced by more robust alternatives. |
| 139 | * Improved peer state machine algorithm to counter SCTP multistream race |
| 140 | condition. |
| 141 | * New extension rt_redirect.fdx that handles the Diameter Redirect errors. |
| 142 | * New extension app_redirect that allows sending Redirect indications to |
| 143 | other peers. See doc/app_redirect.conf.sample for more information. |
| 144 | * Added incomplete dictionary extension for rfc4006 (DCCA), courtesy |
| 145 | of Konstantin Chekushin <koch@lmt.lv> |
| 146 | |
| 147 | -- Sebastien Decugis <sdecugis@freediameter.net> Tue, 29 Mar 2011 10:41:19 +0900 |
| 148 | |
| 149 | freediameter (1.0.4) UNRELEASED; urgency=low |
| 150 | |
| 151 | * Added new API to specify timeout on receiving answer (#10) |
| 152 | * Bumped API version number accordingly. |
| 153 | * New test_netemul extension (simple network emulator proxy) |
| 154 | * Improved API compatibility to C++ compilers |
| 155 | |
| 156 | -- Sebastien Decugis <sdecugis@nict.go.jp> Tue, 11 Jan 2011 12:28:22 +0900 |
| 157 | |
| 158 | freediameter (1.0.3) UNRELEASED; urgency=low |
| 159 | |
| 160 | * Fixed a couple of issues for portability (#21, #22, #23) |
| 161 | * Fixed issue with ListenOn bit ordering (#20) |
| 162 | * Added dictionary support for MIPv6 application objects. |
| 163 | * Added dictionary support for legacy XML files. |
| 164 | * Added python interface dbg_interactive (experimental). |
| 165 | * Added parameters to fd_disp_register() and fd_sess_handler_create(), |
| 166 | Bumped API version number accordingly. |
| 167 | |
| 168 | -- Sebastien Decugis <sdecugis@nict.go.jp> Tue, 14 Dec 2010 11:39:29 +0900 |
| 169 | |
| 170 | freediameter (1.0.2) UNRELEASED; urgency=low |
| 171 | |
| 172 | * Fix an issue in app_diameap.fdx with user names (#18) |
| 173 | * Allow DH parameters loaded from a file (#17) |
| 174 | * Fixed a few compilation warnings on 64bits architectures. |
| 175 | * New ALL_EXTENSIONS build option. |
| 176 | |
| 177 | -- Sebastien Decugis <sdecugis@nict.go.jp> Wed, 27 Oct 2010 11:17:32 +0900 |
| 178 | |
| 179 | freediameter (1.0.1) UNRELEASED; urgency=low |
| 180 | |
| 181 | * app_acct.fdx: new set of PHP scripts available in source |
| 182 | contrib/app_acct_tools |
| 183 | * app_acct.fdx: new directive 'Server_name_field' in the |
| 184 | configuration. |
| 185 | * app_radgw.fdx: new directive 'nonai' in acct and auth plugins to |
| 186 | disable NAI processing. |
| 187 | * app_radgw.fdx: New support for RADIUS proxies. |
| 188 | * app_radgw.fdx: many bug fixes. |
| 189 | * daemon: Check the local certificate is valid during TLS |
| 190 | initialization. |
| 191 | * daemon: Fixed issue for IP addresses in the form x.x.x.235 |
| 192 | * daemon: new option --dbg_gnutls to get GNUTLS debug messages. |
| 193 | * debian: some cleanups in the packaging (dependencies, meta-data) |
| 194 | * rt_ereg.fdx: New routing extension based on regular expression |
| 195 | matching in package freediameter-daemon. |
| 196 | |
| 197 | -- Sebastien Decugis <sdecugis@nict.go.jp> Wed, 15 Sep 2010 18:30:28 +0900 |
| 198 | |
| 199 | freediameter (1.0.0-2) experimental; urgency=low |
| 200 | |
| 201 | * Official release 1.0.0 |
| 202 | |
| 203 | -- Sebastien Decugis <sdecugis@nict.go.jp> Thu, 29 Jul 2010 17:27:13 +0900 |
| 204 | |
| 205 | freediameter (1.0.0-1) experimental; urgency=low |
| 206 | |
| 207 | * Initial Release. |
| 208 | |
| 209 | -- Sebastien Decugis <sdecugis@nict.go.jp> Wed, 19 May 2010 15:36:54 +0900 |