Brian Waters | 13d9601 | 2017-12-08 16:53:31 -0600 | [diff] [blame] | 1 | #!/usr/bin/make -f |
| 2 | # -*- makefile -*- |
| 3 | # Sample debian/rules that uses debhelper. |
| 4 | # |
| 5 | # This file was originally written by Joey Hess and Craig Small. |
| 6 | # As a special exception, when this file is copied by dh-make into a |
| 7 | # dh-make output file, you may use that output file without restriction. |
| 8 | # This special exception was added by Craig Small in version 0.37 of dh-make. |
| 9 | # |
| 10 | # Modified to make a template file for a multi-binary package with separated |
| 11 | # build-arch and build-indep targets by Bill Allombert 2001 |
| 12 | |
| 13 | # Uncomment this to turn on verbose mode. |
| 14 | #export DH_VERBOSE=1 |
| 15 | |
| 16 | # This has to be exported to make some magic below work. |
| 17 | export DH_OPTIONS |
| 18 | |
| 19 | # Comment this out if you want to include the tests when the package is built |
| 20 | skip_the_tests=-DBUILD_TESTING:BOOL=OFF |
| 21 | |
| 22 | %: |
| 23 | dh $@ |
| 24 | |
| 25 | override_dh_auto_configure: |
| 26 | dh_auto_configure -- $(skip_the_tests) \ |
| 27 | -DCMAKE_BUILD_TYPE:STRING=DebianPackage \ |
| 28 | -DDEFAULT_CONF_PATH:PATH=/etc/freeDiameter \ |
| 29 | -DALL_EXTENSIONS:BOOL=ON |
| 30 | |
| 31 | |