| #!/bin/bash |
| |
| # Copyright 2018-present Open Networking Foundation |
| # |
| # This program is free software: you can redistribute it and/or modify |
| # it under the terms of the GNU General Public License as published by |
| # the Free Software Foundation, either version 3 of the License, or |
| # (at your option) any later version. |
| # |
| # This program is distributed in the hope that it will be useful, |
| # but WITHOUT ANY WARRANTY; without even the implied warranty of |
| # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the |
| # GNU General Public License for more details. |
| # |
| # You should have received a copy of the GNU General Public License |
| # along with this program. If not, see <http://www.gnu.org/licenses/>. |
| |
| rm -rf /opt/bcm68620 |
| rm -rf /broadcom |
| tar zxf /tmp/release_asfvolt16_V3.1.1.201908010203.tar.gz -C / 2>&1 > /dev/null |
| grep -q '\/opt\/bcm68620\/svk_init.sh' /etc/rc.local || sed -i -e '$i \/opt\/bcm68620\/svk_init.sh' /etc/rc.local |
| rm -f /run/bcm68620 |
| cp /tmp/init.d/dev_mgmt_daemon /etc/init.d |
| cp /tmp/init.d/openolt /etc/init.d |
| cp /tmp/logrotate.d/openolt /etc/logrotate.d |
| chmod +x /etc/init.d/dev_mgmt_daemon |
| chmod +x /etc/init.d/openolt |
| update-rc.d dev_mgmt_daemon defaults |
| update-rc.d openolt defaults |
| mv /tmp/openolt /broadcom |
| mv /tmp/libgrpc++.so.1 /usr/local/lib |
| mv /tmp/libgrpc.so.6 /usr/local/lib |
| mv /tmp/libstdc++.so.6 /usr/local/lib |
| mv /tmp/libbal_host_api.so /usr/local/lib |
| /opt/bcm68620/svk_init.sh |
| [ "A`cat ~/.bashrc| grep LD_LIBRARY_PATH`" = "A" ] && echo "export LD_LIBRARY_PATH=/broadcom:\$LD_LIBRARY_PATH" >> ~/.bashrc; . ~/.bashrc |
| ldconfig /broadcom |