blob: f2709c59a45baac2a6fafc2e67e4c9ebd5d13d61 [file] [log] [blame]
Shad Ansari6cd46a62018-05-13 23:20:51 +00001#!/bin/bash
2
Zack Williams477ba092018-10-17 10:50:06 -07003# Copyright 2018-present Open Networking Foundation
4#
5# This program is free software: you can redistribute it and/or modify
6# it under the terms of the GNU General Public License as published by
7# the Free Software Foundation, either version 3 of the License, or
8# (at your option) any later version.
9#
10# This program is distributed in the hope that it will be useful,
11# but WITHOUT ANY WARRANTY; without even the implied warranty of
12# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
13# GNU General Public License for more details.
14#
15# You should have received a copy of the GNU General Public License
16# along with this program. If not, see <http://www.gnu.org/licenses/>.
17
Shad Ansaricb004c52018-05-30 18:07:23 +000018rm -rf /opt/bcm68620
19rm -rf /broadcom
20tar zxf /tmp/release_asfvolt16_V02.06.201804301043.tar.gz -C / 2>&1 > /dev/null
21grep -q '\/opt\/bcm68620\/svk_init.sh' /etc/rc.local || sed -i -e '$i \/opt\/bcm68620\/svk_init.sh' /etc/rc.local
22rm -f /run/bcm68620
Shad Ansarid0eaf752018-08-16 00:26:12 +000023cp /tmp/init.d/bal_core_dist /etc/init.d
24cp /tmp/init.d/openolt /etc/init.d
Nicolas Palpacuer967438f2018-09-07 14:41:54 -040025cp /tmp/logrotate.d/openolt /etc/logrotate.d
Shad Ansarid0eaf752018-08-16 00:26:12 +000026chmod +x /etc/init.d/bal_core_dist
27chmod +x /etc/init.d/openolt
28update-rc.d bal_core_dist defaults
29update-rc.d openolt defaults
Shad Ansari9fb007d2018-05-14 18:31:38 +000030mv /tmp/openolt /broadcom
Shad Ansari9fb007d2018-05-14 18:31:38 +000031mv /tmp/libgrpc++.so.1 /usr/local/lib
32mv /tmp/libgrpc.so.6 /usr/local/lib
Shad Ansarif1e0bc82018-05-21 17:51:45 +000033mv /broadcom/libbal_api_dist.so /usr/local/lib
Shad Ansaricb004c52018-05-30 18:07:23 +000034/opt/bcm68620/svk_init.sh
Shad Ansarid0eaf752018-08-16 00:26:12 +000035#service bal_core_dist start
36#service openolt start