Arthur Syu | 094df16 | 2022-04-21 17:50:06 +0800 | [diff] [blame] | 1 | #!/bin/bash |
| 2 | |
| 3 | #Copyright 2018-present Open Networking Foundation |
| 4 | # |
| 5 | #Licensed under the Apache License, Version 2.0 (the "License"); |
| 6 | #you may not use this file except in compliance with the License. |
| 7 | #You may obtain a copy of the License at |
| 8 | # |
| 9 | #http://www.apache.org/licenses/LICENSE-2.0 |
| 10 | # |
| 11 | #Unless required by applicable law or agreed to in writing, software |
| 12 | #distributed under the License is distributed on an "AS IS" BASIS, |
| 13 | #WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. |
| 14 | #See the License for the specific language governing permissions and |
| 15 | #limitations under the License. |
| 16 | |
| 17 | |
| 18 | rm -rf /opt/bcm68620 |
| 19 | tar zxf /tmp/release_sda3016ss_custom_V2.0.0.1-20220425.tar.gz --strip-components=1 -C / 2>&1 > /dev/null |
| 20 | tar zxf /tmp/release_sda3016ss_V3.10.0.0-20220425.tar.gz --strip-components=1 -C / 2>&1 > /dev/null |
| 21 | rm -f /tmp/release_sda3016ss_custom_V2.0.0.1-20220425.tar.gz |
| 22 | rm -f /tmp/release_sda3016ss_V3.10.0.0-20220425.tar.gz |
| 23 | ln -sf /lib/platform-config/x86-64-zyxel-sda3016ss-r0/onl/lib/libonlp-x86-64-zyxel-sda3016ss.so /lib/platform-config/x86-64-zyxel-sda3016ss-r0/onl/lib/libonlp-x86-64-zyxel-sda3016ss.so.1 |
| 24 | chmod +x /opt/bcm68620/sda3016ss/htp/htpNniLb |
| 25 | chmod +x /opt/bcm68620/sda3016ss/htp/htpPonLb |
| 26 | chmod +x /etc/init.d/dev_mgmt_svc |
| 27 | chmod +x /etc/init.d/openolt |
| 28 | chmod +x /etc/init.d/hwmon_svc |
| 29 | chmod +x /etc/init.d/htp_svc |
| 30 | update-rc.d dev_mgmt_svc defaults |
| 31 | update-rc.d openolt defaults |
| 32 | update-rc.d hwmon_svc defaults |
| 33 | update-rc.d htp_svc defaults |
| 34 | mkdir -p /tmp/bcmpon |
| 35 | echo "0:0,1:0" > /tmp/bcmpon/bcm68650_chip_reset |
| 36 | |
| 37 | tar zxf /tmp/release_sda3016ss_openolt_V3.10.0.0-20220425.tar.gz -C / --strip-components=1 |
| 38 | rm -f /tmp/release_sda3016ss_openolt_V3.10.0.0-20220425.tar.gz |
| 39 | |