blob: dab5f11ccf1592d8dcbd748930db6fe78eb416e0 [file] [log] [blame]
Siobhan Tully44fd4cc2014-02-23 00:07:12 -05001Summary: OpenCloud core services
2Name: opencloud
3Version: 1.0
4Release: 1
5License: GPL+
6Group: Development/Tools
7Source0: %{_tmppath}/%{name}-%{version}.tar.gz
8BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}
9requires: postgresql
10requires: postgresql-server
11requires: python-psycopg2
12requires: graphviz
13requires: graphviz-devel
14requires: graphviz-python
15requires: libxslt-devel
16requires: python-pip
17requires: tar
18requires: gcc
19
20%description
21%{summary}
22
23%prep
24%setup -q
25
26%build
27# Empty section.
28
29%pre
30pip-python install django==1.5
31pip-python install djangorestframework
32pip-python install markdown # Markdown support for the browseable API.
33pip-python install pyyaml # YAML content-type support.
34pip-python install django-filter # Filtering support
35pip-python install lxml # XML manipulation library
36pip-python install netaddr # IP Addr library
37pip-python install pytz
38pip-python install django-timezones
39pip-python install requests
40pip-python install django-crispy-forms
41pip-python install django-geoposition
42pip-python install django-extensions
43pip-python install django-suit
44pip-python install django-evolution
45
46easy_install django_evolution
47
48%install
49rm -rf %{buildroot}
50mkdir -p %{buildroot}
51install -d %{buildroot}/opt/planetstack
52
53# in builddir
54cp -rp /opt/plstackapi/planetstack %{buildroot}/opt/.
55
56find %{buildroot}/opt/planetstack -type f -print | sed "s@^$RPM_BUILD_ROOT@@g" > %{_tmppath}/tmp-filelist
57
58%clean
59rm -rf %{buildroot}
60
61%files -f %{_tmppath}/tmp-filelist
62%defattr(-,root,root,-)
63
64%post
65/opt/planetstack/scripts/opencloud initdb
66
67%preun
68rm -rf /opt/planetstack
69
70%changelog
71* Sat Feb 22 2014 Siobhan Tully 1.0.0
72- First Build
73