blob: 845ecf6ba9dd00e7dc8dc0f33bb52ada9c2db068 [file] [log] [blame]
Shad Ansari6cd46a62018-05-13 23:20:51 +00001#!/bin/bash
2
Girish Gowdraa707e7c2019-11-07 11:36:13 +05303#Copyright 2018-present Open Networking Foundation
Zack Williams477ba092018-10-17 10:50:06 -07004#
Girish Gowdraa707e7c2019-11-07 11:36:13 +05305#Licensed under the Apache License, Version 2.0 (the "License");
6#you may not use this file except in compliance with the License.
7#You may obtain a copy of the License at
Zack Williams477ba092018-10-17 10:50:06 -07008#
Girish Gowdraa707e7c2019-11-07 11:36:13 +05309#http://www.apache.org/licenses/LICENSE-2.0
Zack Williams477ba092018-10-17 10:50:06 -070010#
Girish Gowdraa707e7c2019-11-07 11:36:13 +053011#Unless required by applicable law or agreed to in writing, software
12#distributed under the License is distributed on an "AS IS" BASIS,
13#WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
14#See the License for the specific language governing permissions and
15#limitations under the License.
16
Zack Williams477ba092018-10-17 10:50:06 -070017
Shad Ansaricb004c52018-05-30 18:07:23 +000018rm -rf /opt/bcm68620
19rm -rf /broadcom
Girish Gowdracb175002020-09-28 10:53:18 -070020tar zxf /tmp/release_asfvolt16_V3.4.7.5.202008030101.tar.gz -C / 2>&1 > /dev/null
Shad Ansaricb004c52018-05-30 18:07:23 +000021grep -q '\/opt\/bcm68620\/svk_init.sh' /etc/rc.local || sed -i -e '$i \/opt\/bcm68620\/svk_init.sh' /etc/rc.local
22rm -f /run/bcm68620
Girish Gowdra70feafd2020-08-06 20:08:26 -070023mkdir -p /opt/openolt && cp /tmp/watchdog/openolt_dev_mgmt_daemon_process_watchdog /opt/openolt && cp /tmp/watchdog/watchdog.config /opt/openolt
Girish Gowdra6e745522020-07-15 15:52:13 -070024[ -f /opt/openolt/openolt_dev_mgmt_daemon_process_watchdog ] && grep -q '\/opt\/openolt\/openolt_dev_mgmt_daemon_process_watchdog' /etc/rc.local || sed -i -e '$i nohup bash \/opt\/openolt\/openolt_dev_mgmt_daemon_process_watchdog &' /etc/rc.local
Thiyagarajan Subramani89fffc02019-05-13 21:33:20 +000025cp /tmp/init.d/dev_mgmt_daemon /etc/init.d
Shad Ansarid0eaf752018-08-16 00:26:12 +000026cp /tmp/init.d/openolt /etc/init.d
Nicolas Palpacuer967438f2018-09-07 14:41:54 -040027cp /tmp/logrotate.d/openolt /etc/logrotate.d
Thiyagarajan Subramani89fffc02019-05-13 21:33:20 +000028chmod +x /etc/init.d/dev_mgmt_daemon
Shad Ansarid0eaf752018-08-16 00:26:12 +000029chmod +x /etc/init.d/openolt
Girish Gowdra6e745522020-07-15 15:52:13 -070030chmod +x /opt/openolt/openolt_dev_mgmt_daemon_process_watchdog
Thiyagarajan Subramani89fffc02019-05-13 21:33:20 +000031update-rc.d dev_mgmt_daemon defaults
Shad Ansarid0eaf752018-08-16 00:26:12 +000032update-rc.d openolt defaults
Shad Ansari9fb007d2018-05-14 18:31:38 +000033mv /tmp/openolt /broadcom
Shad Ansari9fb007d2018-05-14 18:31:38 +000034mv /tmp/libgrpc++.so.1 /usr/local/lib
35mv /tmp/libgrpc.so.6 /usr/local/lib
Thiyagarajan Subramani89fffc02019-05-13 21:33:20 +000036mv /tmp/libstdc++.so.6 /usr/local/lib
37mv /tmp/libbal_host_api.so /usr/local/lib
Shad Ansaricb004c52018-05-30 18:07:23 +000038/opt/bcm68620/svk_init.sh
Thiyagarajan Subramani89fffc02019-05-13 21:33:20 +000039[ "A`cat ~/.bashrc| grep LD_LIBRARY_PATH`" = "A" ] && echo "export LD_LIBRARY_PATH=/broadcom:\$LD_LIBRARY_PATH" >> ~/.bashrc; . ~/.bashrc
40ldconfig /broadcom