blob: 45bc8496851f4bafe01037cc504b0ff2d251e6b1 [file] [log] [blame]
Siobhan Tully44fd4cc2014-02-23 00:07:12 -05001Summary: OpenCloud core services
2Name: opencloud
Scott Baker524acdb2014-03-19 23:45:49 -07003Version: 1.0.2
Siobhan Tully44fd4cc2014-02-23 00:07:12 -05004Release: 1
5License: GPL+
6Group: Development/Tools
7Source0: %{_tmppath}/%{name}-%{version}.tar.gz
8BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}
9requires: postgresql
10requires: postgresql-server
11requires: python-psycopg2
12requires: graphviz
13requires: graphviz-devel
14requires: graphviz-python
15requires: libxslt-devel
16requires: python-pip
17requires: tar
18requires: gcc
Scott Baker524acdb2014-03-19 23:45:49 -070019requires: python-httplib2
Siobhan Tully44fd4cc2014-02-23 00:07:12 -050020
21%description
22%{summary}
23
24%prep
25%setup -q
26
27%build
28# Empty section.
29
30%pre
31pip-python install django==1.5
32pip-python install djangorestframework
33pip-python install markdown # Markdown support for the browseable API.
34pip-python install pyyaml # YAML content-type support.
35pip-python install django-filter # Filtering support
36pip-python install lxml # XML manipulation library
37pip-python install netaddr # IP Addr library
38pip-python install pytz
39pip-python install django-timezones
40pip-python install requests
41pip-python install django-crispy-forms
42pip-python install django-geoposition
43pip-python install django-extensions
44pip-python install django-suit
45pip-python install django-evolution
Scott Baker524acdb2014-03-19 23:45:49 -070046pip-python install django-bitfield
Siobhan Tully44fd4cc2014-02-23 00:07:12 -050047
48easy_install django_evolution
Scott Baker524acdb2014-03-19 23:45:49 -070049easy_install python_gflags
50easy_install google_api_python_client
51
52wget -P /usr/lib/python2.7/site-packages/suit/static/suit/js http://code.jquery.com/jquery-1.9.1.min.js
Siobhan Tully44fd4cc2014-02-23 00:07:12 -050053
54%install
55rm -rf %{buildroot}
56mkdir -p %{buildroot}
57install -d %{buildroot}/opt/planetstack
58
59# in builddir
60cp -rp /opt/plstackapi/planetstack %{buildroot}/opt/.
61
62find %{buildroot}/opt/planetstack -type f -print | sed "s@^$RPM_BUILD_ROOT@@g" > %{_tmppath}/tmp-filelist
63
64%clean
65rm -rf %{buildroot}
66
67%files -f %{_tmppath}/tmp-filelist
68%defattr(-,root,root,-)
69
70%post
71/opt/planetstack/scripts/opencloud initdb
72
73%preun
74rm -rf /opt/planetstack
75
76%changelog
77* Sat Feb 22 2014 Siobhan Tully 1.0.0
78- First Build
79