blob: 256a190f380b128ab8ae74c5cdb7b1c296a0384c [file] [log] [blame]
Siobhan Tully44fd4cc2014-02-23 00:07:12 -05001Summary: OpenCloud core services
2Name: opencloud
Scott Baker09c7af42014-04-14 11:00:25 -07003Version: 1.0.7
Scott Baker4cd29252014-04-08 23:47:11 -07004Release: 1
Siobhan Tully44fd4cc2014-02-23 00:07:12 -05005License: GPL+
6Group: Development/Tools
7Source0: %{_tmppath}/%{name}-%{version}.tar.gz
8BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}
9requires: postgresql
10requires: postgresql-server
11requires: python-psycopg2
12requires: graphviz
13requires: graphviz-devel
14requires: graphviz-python
15requires: libxslt-devel
16requires: python-pip
17requires: tar
18requires: gcc
Scott Baker524acdb2014-03-19 23:45:49 -070019requires: python-httplib2
Scott Baker09c7af42014-04-14 11:00:25 -070020requires: GeoIP
Siobhan Tully44fd4cc2014-02-23 00:07:12 -050021
22%description
23%{summary}
24
25%prep
26%setup -q
27
28%build
29# Empty section.
30
31%pre
32pip-python install django==1.5
33pip-python install djangorestframework
34pip-python install markdown # Markdown support for the browseable API.
35pip-python install pyyaml # YAML content-type support.
36pip-python install django-filter # Filtering support
37pip-python install lxml # XML manipulation library
38pip-python install netaddr # IP Addr library
39pip-python install pytz
40pip-python install django-timezones
41pip-python install requests
42pip-python install django-crispy-forms
43pip-python install django-geoposition
44pip-python install django-extensions
45pip-python install django-suit
46pip-python install django-evolution
Scott Baker524acdb2014-03-19 23:45:49 -070047pip-python install django-bitfield
Scott Baker09c7af42014-04-14 11:00:25 -070048pip-python install django-ipware
Siobhan Tully44fd4cc2014-02-23 00:07:12 -050049
50easy_install django_evolution
Scott Baker524acdb2014-03-19 23:45:49 -070051easy_install python_gflags
52easy_install google_api_python_client
53
54wget -P /usr/lib/python2.7/site-packages/suit/static/suit/js http://code.jquery.com/jquery-1.9.1.min.js
Siobhan Tully44fd4cc2014-02-23 00:07:12 -050055
56%install
57rm -rf %{buildroot}
58mkdir -p %{buildroot}
59install -d %{buildroot}/opt/planetstack
60
61# in builddir
62cp -rp /opt/plstackapi/planetstack %{buildroot}/opt/.
63
64find %{buildroot}/opt/planetstack -type f -print | sed "s@^$RPM_BUILD_ROOT@@g" > %{_tmppath}/tmp-filelist
65
66%clean
67rm -rf %{buildroot}
68
69%files -f %{_tmppath}/tmp-filelist
70%defattr(-,root,root,-)
71
72%post
73/opt/planetstack/scripts/opencloud initdb
74
75%preun
Scott Baker4cd29252014-04-08 23:47:11 -070076if [ "$1" = 0 ] ; then
Scott Baker09c7af42014-04-14 11:00:25 -070077 echo "doing preuninstall"
Scott Baker4cd29252014-04-08 23:47:11 -070078 rm -rf /opt/planetstack
79fi
Siobhan Tully44fd4cc2014-02-23 00:07:12 -050080
81%changelog
82* Sat Feb 22 2014 Siobhan Tully 1.0.0
83- First Build
84