blob: acd9282f168a35ecd143d511f79c57846f471973 [file] [log] [blame]
Siobhan Tully44fd4cc2014-02-23 00:07:12 -05001Summary: OpenCloud core services
2Name: opencloud
Scott Bakerc00bbfc2014-05-13 17:43:02 -07003Version: 1.0.10
Scott Baker94380352014-05-15 15:06:08 -07004Release: 3
Siobhan Tully44fd4cc2014-02-23 00:07:12 -05005License: GPL+
6Group: Development/Tools
7Source0: %{_tmppath}/%{name}-%{version}.tar.gz
8BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}
9requires: postgresql
10requires: postgresql-server
11requires: python-psycopg2
12requires: graphviz
13requires: graphviz-devel
14requires: graphviz-python
15requires: libxslt-devel
16requires: python-pip
17requires: tar
18requires: gcc
Scott Baker524acdb2014-03-19 23:45:49 -070019requires: python-httplib2
Scott Baker09c7af42014-04-14 11:00:25 -070020requires: GeoIP
Siobhan Tully44fd4cc2014-02-23 00:07:12 -050021
22%description
23%{summary}
24
25%prep
26%setup -q
27
28%build
29# Empty section.
30
31%pre
32pip-python install django==1.5
33pip-python install djangorestframework
34pip-python install markdown # Markdown support for the browseable API.
35pip-python install pyyaml # YAML content-type support.
36pip-python install django-filter # Filtering support
37pip-python install lxml # XML manipulation library
38pip-python install netaddr # IP Addr library
39pip-python install pytz
40pip-python install django-timezones
41pip-python install requests
42pip-python install django-crispy-forms
43pip-python install django-geoposition
44pip-python install django-extensions
45pip-python install django-suit
46pip-python install django-evolution
Scott Baker524acdb2014-03-19 23:45:49 -070047pip-python install django-bitfield
Scott Baker09c7af42014-04-14 11:00:25 -070048pip-python install django-ipware
Siobhan Tully44fd4cc2014-02-23 00:07:12 -050049
50easy_install django_evolution
Scott Baker524acdb2014-03-19 23:45:49 -070051easy_install python_gflags
52easy_install google_api_python_client
53
54wget -P /usr/lib/python2.7/site-packages/suit/static/suit/js http://code.jquery.com/jquery-1.9.1.min.js
Siobhan Tully44fd4cc2014-02-23 00:07:12 -050055
Scott Baker566c0022014-04-18 16:14:04 -070056if [ ! -f /usr/share/GeoIP/GeoLiteCity.dat ]; then
57 rm -f /usr/share/GeoIP/GeoLiteCity.*
58 wget -P /usr/share/GeoIP http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz
59 gzip -d /usr/share/GeoIP/GeoLiteCity*.gz
60fi
Scott Bakeredec3322014-04-14 23:51:04 -070061
Scott Baker91d769f2014-05-15 14:23:22 -070062if [ "$1" == 2 ] ; then
63 echo "UPGRADE - saving current state"
64 /opt/planetstack/scripts/opencloud dumpdata
65fi
66
Siobhan Tully44fd4cc2014-02-23 00:07:12 -050067%install
68rm -rf %{buildroot}
69mkdir -p %{buildroot}
70install -d %{buildroot}/opt/planetstack
71
72# in builddir
Scott Bakerc00bbfc2014-05-13 17:43:02 -070073cp -rp ./planetstack %{buildroot}/opt/.
Siobhan Tully44fd4cc2014-02-23 00:07:12 -050074
75find %{buildroot}/opt/planetstack -type f -print | sed "s@^$RPM_BUILD_ROOT@@g" > %{_tmppath}/tmp-filelist
76
77%clean
78rm -rf %{buildroot}
79
80%files -f %{_tmppath}/tmp-filelist
81%defattr(-,root,root,-)
82
83%post
Scott Bakere7df4a12014-05-15 14:21:31 -070084if [ "$1" == 1 ] ; then
85 echo "NEW INSTALL - initializing database"
86 /opt/planetstack/scripts/opencloud initdb
87else
88 echo "UPGRADE - doing evolution"
89 /opt/planetstack/scripts/opencloud evolvedb
90fi
91# start the server
92/opt/planetstack/scripts/opencloud runserver
Siobhan Tully44fd4cc2014-02-23 00:07:12 -050093
94%preun
Scott Baker4cd29252014-04-08 23:47:11 -070095if [ "$1" = 0 ] ; then
Scott Bakere7df4a12014-05-15 14:21:31 -070096 echo "UNINSTALL - destroying planetstack"
Scott Baker4cd29252014-04-08 23:47:11 -070097 rm -rf /opt/planetstack
98fi
Siobhan Tully44fd4cc2014-02-23 00:07:12 -050099
100%changelog
101* Sat Feb 22 2014 Siobhan Tully 1.0.0
102- First Build
103