blob: 3420bdf8ddfed51df205def212fd71ff4566e34f [file] [log] [blame]
Siobhan Tully44fd4cc2014-02-23 00:07:12 -05001Summary: OpenCloud core services
2Name: opencloud
Scott Baker09c7af42014-04-14 11:00:25 -07003Version: 1.0.7
Scott Baker4cd29252014-04-08 23:47:11 -07004Release: 1
Siobhan Tully44fd4cc2014-02-23 00:07:12 -05005License: GPL+
6Group: Development/Tools
7Source0: %{_tmppath}/%{name}-%{version}.tar.gz
8BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}
9requires: postgresql
10requires: postgresql-server
11requires: python-psycopg2
12requires: graphviz
13requires: graphviz-devel
14requires: graphviz-python
15requires: libxslt-devel
16requires: python-pip
17requires: tar
18requires: gcc
Scott Baker524acdb2014-03-19 23:45:49 -070019requires: python-httplib2
Scott Baker09c7af42014-04-14 11:00:25 -070020requires: GeoIP
Siobhan Tully44fd4cc2014-02-23 00:07:12 -050021
22%description
23%{summary}
24
25%prep
26%setup -q
27
28%build
29# Empty section.
30
31%pre
32pip-python install django==1.5
33pip-python install djangorestframework
34pip-python install markdown # Markdown support for the browseable API.
35pip-python install pyyaml # YAML content-type support.
36pip-python install django-filter # Filtering support
37pip-python install lxml # XML manipulation library
38pip-python install netaddr # IP Addr library
39pip-python install pytz
40pip-python install django-timezones
41pip-python install requests
42pip-python install django-crispy-forms
43pip-python install django-geoposition
44pip-python install django-extensions
45pip-python install django-suit
46pip-python install django-evolution
Scott Baker524acdb2014-03-19 23:45:49 -070047pip-python install django-bitfield
Scott Baker09c7af42014-04-14 11:00:25 -070048pip-python install django-ipware
Siobhan Tully44fd4cc2014-02-23 00:07:12 -050049
50easy_install django_evolution
Scott Baker524acdb2014-03-19 23:45:49 -070051easy_install python_gflags
52easy_install google_api_python_client
53
54wget -P /usr/lib/python2.7/site-packages/suit/static/suit/js http://code.jquery.com/jquery-1.9.1.min.js
Siobhan Tully44fd4cc2014-02-23 00:07:12 -050055
Scott Bakeredec3322014-04-14 23:51:04 -070056rm -f /usr/share/GeoIP/GeoLiteCity*
57wget -P /usr/share/GeoIP http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz
58gzip -d /usr/share/GeoIP/GeoLiteCity*.gz
59
Siobhan Tully44fd4cc2014-02-23 00:07:12 -050060%install
61rm -rf %{buildroot}
62mkdir -p %{buildroot}
63install -d %{buildroot}/opt/planetstack
64
65# in builddir
66cp -rp /opt/plstackapi/planetstack %{buildroot}/opt/.
67
68find %{buildroot}/opt/planetstack -type f -print | sed "s@^$RPM_BUILD_ROOT@@g" > %{_tmppath}/tmp-filelist
69
70%clean
71rm -rf %{buildroot}
72
73%files -f %{_tmppath}/tmp-filelist
74%defattr(-,root,root,-)
75
76%post
77/opt/planetstack/scripts/opencloud initdb
78
79%preun
Scott Baker4cd29252014-04-08 23:47:11 -070080if [ "$1" = 0 ] ; then
Scott Baker09c7af42014-04-14 11:00:25 -070081 echo "doing preuninstall"
Scott Baker4cd29252014-04-08 23:47:11 -070082 rm -rf /opt/planetstack
83fi
Siobhan Tully44fd4cc2014-02-23 00:07:12 -050084
85%changelog
86* Sat Feb 22 2014 Siobhan Tully 1.0.0
87- First Build
88