blob: 895b9dcd0172d725860d17e096a0e5c1f9047c1a [file] [log] [blame]
Siobhan Tully44fd4cc2014-02-23 00:07:12 -05001Summary: OpenCloud core services
2Name: opencloud
Scott Baker92017862014-09-24 21:32:40 -07003Version: 1.0.27
4Release: 3
Siobhan Tully44fd4cc2014-02-23 00:07:12 -05005License: GPL+
6Group: Development/Tools
7Source0: %{_tmppath}/%{name}-%{version}.tar.gz
8BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}
9requires: postgresql
10requires: postgresql-server
11requires: python-psycopg2
12requires: graphviz
13requires: graphviz-devel
14requires: graphviz-python
15requires: libxslt-devel
16requires: python-pip
17requires: tar
18requires: gcc
Scott Baker524acdb2014-03-19 23:45:49 -070019requires: python-httplib2
Scott Baker09c7af42014-04-14 11:00:25 -070020requires: GeoIP
Sapan Bhatia897d92c2014-10-06 16:59:26 -040021requires: wget
Siobhan Tully44fd4cc2014-02-23 00:07:12 -050022
23%description
24%{summary}
25
26%prep
27%setup -q
28
29%build
30# Empty section.
31
32%pre
Scott Bakerbaf62562014-09-17 22:19:54 -070033pip-python install django==1.7
Siobhan Tully44fd4cc2014-02-23 00:07:12 -050034pip-python install djangorestframework
35pip-python install markdown # Markdown support for the browseable API.
36pip-python install pyyaml # YAML content-type support.
37pip-python install django-filter # Filtering support
38pip-python install lxml # XML manipulation library
39pip-python install netaddr # IP Addr library
40pip-python install pytz
41pip-python install django-timezones
42pip-python install requests
43pip-python install django-crispy-forms
44pip-python install django-geoposition
45pip-python install django-extensions
46pip-python install django-suit
47pip-python install django-evolution
Scott Baker524acdb2014-03-19 23:45:49 -070048pip-python install django-bitfield
Scott Baker09c7af42014-04-14 11:00:25 -070049pip-python install django-ipware
Sapan Bhatia1080a282014-09-08 11:00:29 -040050pip-python install django-encrypted-fields
Scott Bakera1f72802014-09-11 00:25:49 -070051pip-python install python-keyczar
Siobhan Tully44fd4cc2014-02-23 00:07:12 -050052
53easy_install django_evolution
Scott Baker524acdb2014-03-19 23:45:49 -070054easy_install python_gflags
55easy_install google_api_python_client
56
Scott Bakera1f72802014-09-11 00:25:49 -070057if [ ! -f /usr/lib/python2.7/site-packages/suit/static/suit/js/jquery-1.9.1.min.js ]; then
58 wget -P /usr/lib/python2.7/site-packages/suit/static/suit/js http://code.jquery.com/jquery-1.9.1.min.js
59fi
Siobhan Tully44fd4cc2014-02-23 00:07:12 -050060
Scott Baker566c0022014-04-18 16:14:04 -070061if [ ! -f /usr/share/GeoIP/GeoLiteCity.dat ]; then
62 rm -f /usr/share/GeoIP/GeoLiteCity.*
63 wget -P /usr/share/GeoIP http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz
64 gzip -d /usr/share/GeoIP/GeoLiteCity*.gz
65fi
Scott Bakeredec3322014-04-14 23:51:04 -070066
Scott Baker91d769f2014-05-15 14:23:22 -070067if [ "$1" == 2 ] ; then
Scott Baker8ccabb92014-06-25 23:07:54 -070068 if [[ -e /opt/planetstack/scripts/opencloud ]]; then
69 echo "UPGRADE - saving current state"
70 /opt/planetstack/scripts/opencloud dumpdata
71 fi
Scott Baker91d769f2014-05-15 14:23:22 -070072fi
73
Siobhan Tully44fd4cc2014-02-23 00:07:12 -050074%install
75rm -rf %{buildroot}
76mkdir -p %{buildroot}
77install -d %{buildroot}/opt/planetstack
Sapan Bhatiaa4d3e382014-08-04 23:49:52 -040078install -d %{buildroot}/etc/init.d
Siobhan Tully44fd4cc2014-02-23 00:07:12 -050079
80# in builddir
John H. Hartman7a3deca2014-08-11 16:46:27 -070081
82
83# don't copy symbolic links (they are handled in %post)
84rsync -rptgoD ./planetstack %{buildroot}/opt/.
Sapan Bhatia55049402014-08-04 23:45:59 -040085cp observer-initscript %{buildroot}/etc/init.d/plstackobserver
Siobhan Tully44fd4cc2014-02-23 00:07:12 -050086
Scott Baker140f15a2014-05-15 15:14:23 -070087find %{buildroot}/opt/planetstack -type f -print | sed "s@^$RPM_BUILD_ROOT@@g" > %{_tmppath}/tmp-filelist
John H. Hartman7a3deca2014-08-11 16:46:27 -070088echo /etc/init.d/plstackobserver >> %{_tmppath}/tmp-filelist
89
90# remove config files from the file list (see %config below)
91cat > %{_tmppath}/config-files << "EOF"
92/opt/planetstack/plstackapi_config
93/opt/planetstack/deployment_auth.py
94EOF
95
96sort %{_tmppath}/tmp-filelist > %{_tmppath}/tmp-filelist.sorted
97sort %{_tmppath}/config-files > %{_tmppath}/config-files.sorted
98comm -13 %{_tmppath}/config-files.sorted %{_tmppath}/tmp-filelist.sorted > %{_tmppath}/tmp-filelist
99
Scott Baker140f15a2014-05-15 15:14:23 -0700100cp %{_tmppath}/tmp-filelist /tmp/tmp-filelist
Siobhan Tully44fd4cc2014-02-23 00:07:12 -0500101
102%clean
103rm -rf %{buildroot}
104
105%files -f %{_tmppath}/tmp-filelist
106%defattr(-,root,root,-)
Scott Baker140f15a2014-05-15 15:14:23 -0700107%config /opt/planetstack/plstackapi_config
Scott Baker8ccabb92014-06-25 23:07:54 -0700108%config /opt/planetstack/deployment_auth.py
Siobhan Tully44fd4cc2014-02-23 00:07:12 -0500109
110%post
John H. Hartman7a3deca2014-08-11 16:46:27 -0700111ln -s ec2_observer /opt/planetstack/observer
112ln -s config-opencloud.py /opt/planetstack/syndicate_observer/syndicatelib_config/config.py
113
Scott Bakerc44f26c2014-09-12 15:38:24 -0700114if [ ! -e /opt/planetstack/public_keys ]; then
115 cd /opt/planetstack
116 scripts/opencloud genkeys
117fi
118
Scott Bakere7df4a12014-05-15 14:21:31 -0700119if [ "$1" == 1 ] ; then
120 echo "NEW INSTALL - initializing database"
121 /opt/planetstack/scripts/opencloud initdb
122else
Scott Bakerbaf62562014-09-17 22:19:54 -0700123 # scripts/opencloud will choose evolve or migrate depending on django version
124 echo "UPGRADE - doing evolution/migration"
Scott Bakere7df4a12014-05-15 14:21:31 -0700125 /opt/planetstack/scripts/opencloud evolvedb
Scott Bakera1f72802014-09-11 00:25:49 -0700126fi
127
Scott Bakere7df4a12014-05-15 14:21:31 -0700128# start the server
129/opt/planetstack/scripts/opencloud runserver
Siobhan Tully44fd4cc2014-02-23 00:07:12 -0500130
131%preun
Scott Baker4cd29252014-04-08 23:47:11 -0700132if [ "$1" = 0 ] ; then
Scott Bakere7df4a12014-05-15 14:21:31 -0700133 echo "UNINSTALL - destroying planetstack"
Scott Baker4cd29252014-04-08 23:47:11 -0700134 rm -rf /opt/planetstack
135fi
Siobhan Tully44fd4cc2014-02-23 00:07:12 -0500136
137%changelog
138* Sat Feb 22 2014 Siobhan Tully 1.0.0
139- First Build
140