blob: 7fe1605be6d8d7a9904636921d486be71a2d5e22 [file] [log] [blame]
Siobhan Tully44fd4cc2014-02-23 00:07:12 -05001Summary: OpenCloud core services
2Name: opencloud
Scott Baker72ba6d92014-12-19 12:31:35 -08003Version: 1.0.29
4Release: 1
Siobhan Tully44fd4cc2014-02-23 00:07:12 -05005License: GPL+
6Group: Development/Tools
7Source0: %{_tmppath}/%{name}-%{version}.tar.gz
8BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}
9requires: postgresql
10requires: postgresql-server
11requires: python-psycopg2
12requires: graphviz
13requires: graphviz-devel
14requires: graphviz-python
15requires: libxslt-devel
16requires: python-pip
17requires: tar
18requires: gcc
Scott Baker524acdb2014-03-19 23:45:49 -070019requires: python-httplib2
Scott Baker09c7af42014-04-14 11:00:25 -070020requires: GeoIP
Sapan Bhatia897d92c2014-10-06 16:59:26 -040021requires: wget
Siobhan Tully44fd4cc2014-02-23 00:07:12 -050022
23%description
24%{summary}
25
26%prep
27%setup -q
28
29%build
30# Empty section.
31
32%pre
Scott Bakerbaf62562014-09-17 22:19:54 -070033pip-python install django==1.7
Siobhan Tully44fd4cc2014-02-23 00:07:12 -050034pip-python install djangorestframework
35pip-python install markdown # Markdown support for the browseable API.
36pip-python install pyyaml # YAML content-type support.
37pip-python install django-filter # Filtering support
38pip-python install lxml # XML manipulation library
39pip-python install netaddr # IP Addr library
40pip-python install pytz
41pip-python install django-timezones
42pip-python install requests
43pip-python install django-crispy-forms
44pip-python install django-geoposition
45pip-python install django-extensions
46pip-python install django-suit
47pip-python install django-evolution
Scott Baker524acdb2014-03-19 23:45:49 -070048pip-python install django-bitfield
Scott Baker09c7af42014-04-14 11:00:25 -070049pip-python install django-ipware
Sapan Bhatia1080a282014-09-08 11:00:29 -040050pip-python install django-encrypted-fields
Scott Bakera1f72802014-09-11 00:25:49 -070051pip-python install python-keyczar
Tony Mack1d7fb8e2014-10-08 13:47:54 -040052pip-python install python-keystoneclient
53pip-python install python-novaclient
54pip-python install python-neutronclient
55pip-python install python-glanceclient
56
Siobhan Tully44fd4cc2014-02-23 00:07:12 -050057
58easy_install django_evolution
Scott Baker524acdb2014-03-19 23:45:49 -070059easy_install python_gflags
60easy_install google_api_python_client
61
Scott Bakera1f72802014-09-11 00:25:49 -070062if [ ! -f /usr/lib/python2.7/site-packages/suit/static/suit/js/jquery-1.9.1.min.js ]; then
63 wget -P /usr/lib/python2.7/site-packages/suit/static/suit/js http://code.jquery.com/jquery-1.9.1.min.js
64fi
Siobhan Tully44fd4cc2014-02-23 00:07:12 -050065
Scott Baker566c0022014-04-18 16:14:04 -070066if [ ! -f /usr/share/GeoIP/GeoLiteCity.dat ]; then
67 rm -f /usr/share/GeoIP/GeoLiteCity.*
68 wget -P /usr/share/GeoIP http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz
69 gzip -d /usr/share/GeoIP/GeoLiteCity*.gz
70fi
Scott Bakeredec3322014-04-14 23:51:04 -070071
Scott Baker91d769f2014-05-15 14:23:22 -070072if [ "$1" == 2 ] ; then
Scott Baker8ccabb92014-06-25 23:07:54 -070073 if [[ -e /opt/planetstack/scripts/opencloud ]]; then
74 echo "UPGRADE - saving current state"
75 /opt/planetstack/scripts/opencloud dumpdata
76 fi
Scott Baker91d769f2014-05-15 14:23:22 -070077fi
78
Siobhan Tully44fd4cc2014-02-23 00:07:12 -050079%install
80rm -rf %{buildroot}
81mkdir -p %{buildroot}
82install -d %{buildroot}/opt/planetstack
Sapan Bhatiaa4d3e382014-08-04 23:49:52 -040083install -d %{buildroot}/etc/init.d
Siobhan Tully44fd4cc2014-02-23 00:07:12 -050084
85# in builddir
John H. Hartman7a3deca2014-08-11 16:46:27 -070086
87
88# don't copy symbolic links (they are handled in %post)
89rsync -rptgoD ./planetstack %{buildroot}/opt/.
Sapan Bhatia55049402014-08-04 23:45:59 -040090cp observer-initscript %{buildroot}/etc/init.d/plstackobserver
Siobhan Tully44fd4cc2014-02-23 00:07:12 -050091
Scott Baker140f15a2014-05-15 15:14:23 -070092find %{buildroot}/opt/planetstack -type f -print | sed "s@^$RPM_BUILD_ROOT@@g" > %{_tmppath}/tmp-filelist
John H. Hartman7a3deca2014-08-11 16:46:27 -070093echo /etc/init.d/plstackobserver >> %{_tmppath}/tmp-filelist
94
95# remove config files from the file list (see %config below)
96cat > %{_tmppath}/config-files << "EOF"
97/opt/planetstack/plstackapi_config
98/opt/planetstack/deployment_auth.py
99EOF
100
101sort %{_tmppath}/tmp-filelist > %{_tmppath}/tmp-filelist.sorted
102sort %{_tmppath}/config-files > %{_tmppath}/config-files.sorted
103comm -13 %{_tmppath}/config-files.sorted %{_tmppath}/tmp-filelist.sorted > %{_tmppath}/tmp-filelist
104
Scott Baker140f15a2014-05-15 15:14:23 -0700105cp %{_tmppath}/tmp-filelist /tmp/tmp-filelist
Siobhan Tully44fd4cc2014-02-23 00:07:12 -0500106
Sapan Bhatia8fd7b6f2014-11-05 10:38:15 -0500107
Siobhan Tully44fd4cc2014-02-23 00:07:12 -0500108%clean
109rm -rf %{buildroot}
110
111%files -f %{_tmppath}/tmp-filelist
112%defattr(-,root,root,-)
Scott Baker140f15a2014-05-15 15:14:23 -0700113%config /opt/planetstack/plstackapi_config
Scott Baker8ccabb92014-06-25 23:07:54 -0700114%config /opt/planetstack/deployment_auth.py
Sapan Bhatiac6aacf12014-11-14 15:27:33 -0500115%config /opt/planetstack/model-deps
Siobhan Tully44fd4cc2014-02-23 00:07:12 -0500116
117%post
John H. Hartman7a3deca2014-08-11 16:46:27 -0700118ln -s ec2_observer /opt/planetstack/observer
119ln -s config-opencloud.py /opt/planetstack/syndicate_observer/syndicatelib_config/config.py
120
Scott Bakerc44f26c2014-09-12 15:38:24 -0700121if [ ! -e /opt/planetstack/public_keys ]; then
122 cd /opt/planetstack
123 scripts/opencloud genkeys
124fi
125
Scott Bakere7df4a12014-05-15 14:21:31 -0700126if [ "$1" == 1 ] ; then
127 echo "NEW INSTALL - initializing database"
128 /opt/planetstack/scripts/opencloud initdb
129else
Scott Bakerbaf62562014-09-17 22:19:54 -0700130 # scripts/opencloud will choose evolve or migrate depending on django version
131 echo "UPGRADE - doing evolution/migration"
Scott Bakere7df4a12014-05-15 14:21:31 -0700132 /opt/planetstack/scripts/opencloud evolvedb
Scott Bakera1f72802014-09-11 00:25:49 -0700133fi
134
Sapan Bhatiac6aacf12014-11-14 15:27:33 -0500135# Clone ansible with latest openstack modules
136git clone --recursive git://github.com/ansible/ansible.git /opt/ansible
137mkdir -p /etc/ansible
138echo > /etc/ansible/hosts << "EOF"
139[localhost]
140127.0.0.1
141EOF
142
143
Scott Bakere7df4a12014-05-15 14:21:31 -0700144# start the server
145/opt/planetstack/scripts/opencloud runserver
Siobhan Tully44fd4cc2014-02-23 00:07:12 -0500146
147%preun
Scott Baker4cd29252014-04-08 23:47:11 -0700148if [ "$1" = 0 ] ; then
Scott Bakere7df4a12014-05-15 14:21:31 -0700149 echo "UNINSTALL - destroying planetstack"
Scott Baker4cd29252014-04-08 23:47:11 -0700150 rm -rf /opt/planetstack
151fi
Siobhan Tully44fd4cc2014-02-23 00:07:12 -0500152
153%changelog
154* Sat Feb 22 2014 Siobhan Tully 1.0.0
155- First Build
156