Siobhan Tully | 44fd4cc | 2014-02-23 00:07:12 -0500 | [diff] [blame] | 1 | Summary: OpenCloud core services |
| 2 | Name: opencloud |
Scott Baker | 8ccabb9 | 2014-06-25 23:07:54 -0700 | [diff] [blame] | 3 | Version: 1.0.20 |
| 4 | Release: 1 |
Siobhan Tully | 44fd4cc | 2014-02-23 00:07:12 -0500 | [diff] [blame] | 5 | License: GPL+ |
| 6 | Group: Development/Tools |
| 7 | Source0: %{_tmppath}/%{name}-%{version}.tar.gz |
| 8 | BuildRoot: %{_tmppath}/%{name}-%{version}-%{release} |
| 9 | requires: postgresql |
| 10 | requires: postgresql-server |
| 11 | requires: python-psycopg2 |
| 12 | requires: graphviz |
| 13 | requires: graphviz-devel |
| 14 | requires: graphviz-python |
| 15 | requires: libxslt-devel |
| 16 | requires: python-pip |
| 17 | requires: tar |
| 18 | requires: gcc |
Scott Baker | 524acdb | 2014-03-19 23:45:49 -0700 | [diff] [blame] | 19 | requires: python-httplib2 |
Scott Baker | 09c7af4 | 2014-04-14 11:00:25 -0700 | [diff] [blame] | 20 | requires: GeoIP |
Siobhan Tully | 44fd4cc | 2014-02-23 00:07:12 -0500 | [diff] [blame] | 21 | |
| 22 | %description |
| 23 | %{summary} |
| 24 | |
| 25 | %prep |
| 26 | %setup -q |
| 27 | |
| 28 | %build |
| 29 | # Empty section. |
| 30 | |
| 31 | %pre |
Scott Baker | 8ccabb9 | 2014-06-25 23:07:54 -0700 | [diff] [blame] | 32 | #pip-python install django==1.5 |
Siobhan Tully | 44fd4cc | 2014-02-23 00:07:12 -0500 | [diff] [blame] | 33 | pip-python install djangorestframework |
| 34 | pip-python install markdown # Markdown support for the browseable API. |
| 35 | pip-python install pyyaml # YAML content-type support. |
| 36 | pip-python install django-filter # Filtering support |
| 37 | pip-python install lxml # XML manipulation library |
| 38 | pip-python install netaddr # IP Addr library |
| 39 | pip-python install pytz |
| 40 | pip-python install django-timezones |
| 41 | pip-python install requests |
| 42 | pip-python install django-crispy-forms |
| 43 | pip-python install django-geoposition |
| 44 | pip-python install django-extensions |
| 45 | pip-python install django-suit |
| 46 | pip-python install django-evolution |
Scott Baker | 524acdb | 2014-03-19 23:45:49 -0700 | [diff] [blame] | 47 | pip-python install django-bitfield |
Scott Baker | 09c7af4 | 2014-04-14 11:00:25 -0700 | [diff] [blame] | 48 | pip-python install django-ipware |
Siobhan Tully | 44fd4cc | 2014-02-23 00:07:12 -0500 | [diff] [blame] | 49 | |
| 50 | easy_install django_evolution |
Scott Baker | 524acdb | 2014-03-19 23:45:49 -0700 | [diff] [blame] | 51 | easy_install python_gflags |
| 52 | easy_install google_api_python_client |
| 53 | |
| 54 | wget -P /usr/lib/python2.7/site-packages/suit/static/suit/js http://code.jquery.com/jquery-1.9.1.min.js |
Siobhan Tully | 44fd4cc | 2014-02-23 00:07:12 -0500 | [diff] [blame] | 55 | |
Scott Baker | 566c002 | 2014-04-18 16:14:04 -0700 | [diff] [blame] | 56 | if [ ! -f /usr/share/GeoIP/GeoLiteCity.dat ]; then |
| 57 | rm -f /usr/share/GeoIP/GeoLiteCity.* |
| 58 | wget -P /usr/share/GeoIP http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz |
| 59 | gzip -d /usr/share/GeoIP/GeoLiteCity*.gz |
| 60 | fi |
Scott Baker | edec332 | 2014-04-14 23:51:04 -0700 | [diff] [blame] | 61 | |
Scott Baker | 91d769f | 2014-05-15 14:23:22 -0700 | [diff] [blame] | 62 | if [ "$1" == 2 ] ; then |
Scott Baker | 8ccabb9 | 2014-06-25 23:07:54 -0700 | [diff] [blame] | 63 | if [[ -e /opt/planetstack/scripts/opencloud ]]; then |
| 64 | echo "UPGRADE - saving current state" |
| 65 | /opt/planetstack/scripts/opencloud dumpdata |
| 66 | fi |
Scott Baker | 91d769f | 2014-05-15 14:23:22 -0700 | [diff] [blame] | 67 | fi |
| 68 | |
Siobhan Tully | 44fd4cc | 2014-02-23 00:07:12 -0500 | [diff] [blame] | 69 | %install |
| 70 | rm -rf %{buildroot} |
| 71 | mkdir -p %{buildroot} |
| 72 | install -d %{buildroot}/opt/planetstack |
| 73 | |
| 74 | # in builddir |
Scott Baker | c00bbfc | 2014-05-13 17:43:02 -0700 | [diff] [blame] | 75 | cp -rp ./planetstack %{buildroot}/opt/. |
Siobhan Tully | 44fd4cc | 2014-02-23 00:07:12 -0500 | [diff] [blame] | 76 | |
Scott Baker | 140f15a | 2014-05-15 15:14:23 -0700 | [diff] [blame] | 77 | find %{buildroot}/opt/planetstack -type f -print | sed "s@^$RPM_BUILD_ROOT@@g" > %{_tmppath}/tmp-filelist |
| 78 | cp %{_tmppath}/tmp-filelist /tmp/tmp-filelist |
Siobhan Tully | 44fd4cc | 2014-02-23 00:07:12 -0500 | [diff] [blame] | 79 | |
| 80 | %clean |
| 81 | rm -rf %{buildroot} |
| 82 | |
| 83 | %files -f %{_tmppath}/tmp-filelist |
| 84 | %defattr(-,root,root,-) |
Scott Baker | 140f15a | 2014-05-15 15:14:23 -0700 | [diff] [blame] | 85 | %config /opt/planetstack/plstackapi_config |
Scott Baker | 8ccabb9 | 2014-06-25 23:07:54 -0700 | [diff] [blame] | 86 | %config /opt/planetstack/deployment_auth.py |
Siobhan Tully | 44fd4cc | 2014-02-23 00:07:12 -0500 | [diff] [blame] | 87 | |
| 88 | %post |
Scott Baker | e7df4a1 | 2014-05-15 14:21:31 -0700 | [diff] [blame] | 89 | if [ "$1" == 1 ] ; then |
| 90 | echo "NEW INSTALL - initializing database" |
| 91 | /opt/planetstack/scripts/opencloud initdb |
| 92 | else |
| 93 | echo "UPGRADE - doing evolution" |
| 94 | /opt/planetstack/scripts/opencloud evolvedb |
| 95 | fi |
| 96 | # start the server |
| 97 | /opt/planetstack/scripts/opencloud runserver |
Siobhan Tully | 44fd4cc | 2014-02-23 00:07:12 -0500 | [diff] [blame] | 98 | |
| 99 | %preun |
Scott Baker | 4cd2925 | 2014-04-08 23:47:11 -0700 | [diff] [blame] | 100 | if [ "$1" = 0 ] ; then |
Scott Baker | e7df4a1 | 2014-05-15 14:21:31 -0700 | [diff] [blame] | 101 | echo "UNINSTALL - destroying planetstack" |
Scott Baker | 4cd2925 | 2014-04-08 23:47:11 -0700 | [diff] [blame] | 102 | rm -rf /opt/planetstack |
| 103 | fi |
Siobhan Tully | 44fd4cc | 2014-02-23 00:07:12 -0500 | [diff] [blame] | 104 | |
| 105 | %changelog |
| 106 | * Sat Feb 22 2014 Siobhan Tully 1.0.0 |
| 107 | - First Build |
| 108 | |